PHP Update Required – How to fix this?

0
70
php update in wordpress

Blogging does make you learn a lot of things. For e.g. I had no knowledge about making a website. Now, I feel that I am too familiar with WordPress and have created a lot of websites for my friends and known. Today, I woke up and checked my dashboard. I got an unusual warning saying that “PHP update required”. I saw this warning in the Dashboard once I upgraded to WordPress 5.1 PHP Update Required, WordPress has detected that your site is running on an insecure version of PHP.

php update required in wordpress

Let us understand, what is PHP & why PHP update required?

PHP is the coding language of WordPress and they always recommend us to update it to the newest version to ensure the speed and security of our websites. I almost forgot about it until seeing that reminder. In case you are using shared hosting services, you can go to PHP Selector in cPanel to set up your PHP environment.

Hey, I am there on YouTube as well, check out my channel.

Varun, A blogger out in the world to make his mark.

Important things to take care of before updating PHP in WP

  • Back up your Websites: Make a backup of your websites or server before updating PHP version. Although there is a little risk during the process, making a backup is still recommended.
  • Login to your Cpanel of your hosting company.
  • Check the current version of your PHP
  • Disable PHP5 (Or whatever is your current PHP version) and enable PHP 7.3

Follow these screenshots below.

I use hosting from NameCheap, so the images are from my Cpanel. The process, however, will remain the same irrespective of the hosting provider.

Login to the Cpanel of your hosting.
Login to the Cpanel of your hosting and look for select PHP version.
Once you get in the PHP select program it will show you the current version of your PHP
Set the PHP version to 7.3, there you go it’s done. Refresh your dashboard and you will see the difference in the speed.

All done, your WordPress websites should be running on the newest PHP version now and you won’t see the warning again in the Dashboard. The PHP update is really important and I highly recommend you to do it immediately if you haven’t done so. It does not only make your site faster for search engines and for your visitors but also make your website better protected against hackers.

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.